Showing results for 
Search instead for 
Did you mean: 

Software Management

Novitiate II

I have hosted multiple custom applications in an s3 bucket, I am able to validate the URLs and create a software deploy but the applications do not get installed. I am able to install the custom apps when I run directly on the MACs but am not able to install via JC. What could be the issue?


Community Manager Community Manager
Community Manager

This sounds like something you'd need to create a support ticket for @ddeluxe.

Like someone's post? Give them a kudo!
Did someone's answer help you? Please mark it as a solution.

Rising Star II

@ddeluxe If you haven't already, you may want to check your various MDM tokens to ensure they have not expired.   JumpCloud just released a homepage widget that will report on token expiration to help make it more visible.

This actually happened to me just this week...   I was trying to update a custom package, and it failed across the board on deployment.  When I looked into it today I realized that both my Apple MDM and Device Enrollment tokens had expired.   I fixed that and tested the deployment, and it worked this time.

Rising Star II
Rising Star II

Hi @ddeluxe,

The replies below about your MDM Certificate for APNs are right on the money, but there's something else it could be. If your package is not signed with an Apple Developer ID Certificate, it will not install. In addition, if it's signed, but not a Distribution Archive type package, it will not install. Please check to make sure you're using a signed, distribution-style package.